By: Anonymous: Ron650 ()  Wednesday, 22 June 2016 @ 07:29 AM ICT (Read 267 times)  

I have a 2009 Kawasaki Ninja 650R with a good amount of kilometers on the clock. When I took the motorcycle out for a short ride to warm up the engine oil before changing it, the temperature light came on. The radiator, was “strangely” almost empty. I topped it off and have since put about 1000 kilometers on the motorcycle with no problems or leaks. The radiator fan comes on, so that apparently isn't an issue. Do you have any idea what could have caused the coolant loss?

By: news (offline)  Wednesday, 22 June 2016 @ 08:44 AM ICT  

If you haven't found any leaks, and there's no coolant in the engine oil, then it's possible that whoever replaced the coolant didn't follow the correct procedure.

Failure to bleed or 'burp' the air out of the cooling system would result in exactly what you're seeing: low coolant level with not apparent cause.

   

news


Group Comfort
Level:
: +34
Registered:: 27/08/07

Posts: 1917
2 posts :: Page 1 of 1
Advertising

Poll

How many times have you crashed your motorcycle in the last three years?

  •  Never
  •  Once
  •  Twice
  •  Three times
  •  Four times
  •  Five times
  •  More than 6 times
  •  More than 10 times
This poll has 0 more questions.
Results
Other polls | 8,370 votes | 19 Comments
TMEA MEMBER
Thai Motorcycle Enterprise Association
Events
Site Events
Wednesday 30-Nov - Monday 12-Dec
What's New
Stories  last 2 days Media Gallery  last 7 days Files  last 7 days
Motorcycle Thailand on Facebook
Motorcycle Thailand on Facebook
My Account