By: Anonymous: Kiusuke ()  Tuesday, 27 October 2015 @ 05:16 AM ICT (Read 598 times)  

Hello, i have a problem with my motorcycle. I did the usual stuff, warming the engine before riding it etc. After like 15minutes of riding the engine just died on me. The lights and horn work without any problems. I tried to push start it, it did not want to start that way. I took the battery out recharged it, checked the spark plug. The spark is Blue and sometimes mixed with red. The engine cranks but does not start. When i pull out the choke press the ON button and pull the gas i hear something like backfire in the exhaust, but only if i pull the gas without it there is no backfire. I checked the carb it is getting fuel. I checked the Fuse it is not blown or broken. What could be the problem?

I appreciate every kind of help.

By: Flying Squirrel (offline)  Tuesday, 27 October 2015 @ 11:45 AM ICT  

Ride again for 15 mins. When it stops open the fuel tank. Does it hiss when you open? With the fuel tank open does it start normally?

The vent in the fuel filler cap is blocked.


Flying Squirrel

Group Comfort
: +6
Registered:: 23/04/10

Posts: 315
By: ThaiDesign (offline)  Tuesday, 27 October 2015 @ 02:25 PM ICT  

Another problem, but much less likely, could be the exhaust pipe. The blocked fuel tank ventilation is much more likely and happens more often...



Group Comfort
: +30
Registered:: 21/09/07

Posts: 334
3 posts :: Page 1 of 1


How many times have you crashed your motorcycle in the last three years?

  •  Never
  •  Once
  •  Twice
  •  Three times
  •  Four times
  •  Five times
  •  More than 6 times
  •  More than 10 times
This poll has 0 more questions.
Other polls | 8,226 votes | 18 Comments
Thai Motorcycle Enterprise Association
There are no upcoming events
What's New
Stories  last 2 days Links  last 2 weeks
Motorcycle Thailand on Facebook
Motorcycle Thailand on Facebook
My Account